BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
      01-12-2019, 12:49 PM   #1
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Battery Problem

Hi All,

Newbie here. Iíve looked through previous posts for an answer with no luck.

Iím looking for a bit of advice about my 2013 640d coupe. 30k miles.

It sat over Christmas for 2 weeks without getting used, when I started it after the 2 weeks I got a message saying Ďincreased battery discharge whilst stationaryí The wording might not be 100% correct.

I drive my car to work (40miles) and tested the battery which was 12.6v. Drove home later that day and again when I got home 12.6v. Tested it in morning and it had dropped to 12.3v. I left it until later that day and it was 12.1v, left it again for about 12hrs and it read 12.3v again 🤔

I then charged the battery back up and removed it from the car for 36hrs and it still read 12.6v so I reckon the battery is ok. Iíve been told by a mechanic that the alternator is working fine and he doesnít suspect any diode issues as they usually through up some warning lights.

Another weird thing is my car unlocks when I walk towards it, if I stand at the patrol cap area, there is a constant slicking as if the car is constantly unlocking itself however if I move the key fob away from here the clicking stops.

Iím guessing something is draining the battery whilst stationary to bring up the message but what? Donít have anything plugged into any cigarette lighters or any dash cams etc. Or due to in consistent reading is the battery actually gunned.

Any ideas anyone?
Appreciate 0
      01-12-2019, 05:12 PM   #2
Havy
Captain
Havy's Avatar
Germany
270
Rep
687
Posts

Drives: BMW X5 M50i
Join Date: Sep 2018
Location: Europe

iTrader: (0)

The battery is now at least 5 years old, it can happen that it is almost dead. The best way to recharge is driving at least for an hour. You should measure the rest current.
Appreciate 0
      01-16-2019, 01:52 PM   #3
Nummer22
New Member
0
Rep
7
Posts

Drives: 650i xdrive
Join Date: Feb 2014
Location: Netherlands

iTrader: (0)

Why don’t you use the secret menu ? Search how to use.
Appreciate 0
      01-16-2019, 02:27 PM   #4
elvisisdog
Second Lieutenant
33
Rep
200
Posts

Drives: F06 MSport 2013/09
Join Date: Jan 2017
Location: UK

iTrader: (0)

Your clicking sounds like comfort access and the battery in your key fob being low, cheap fix to get a new battery in the key fob. Had exactly this issue on mine. New battery and the issue went away (took a coupe of weeks though - bizarrely).
Appreciate 0
      01-16-2019, 02:42 PM   #5
DMike
New Member
Finland
0
Rep
14
Posts

Drives: BMW Z4 3.0i
Join Date: Jul 2007
Location: Helsinki, Finland

iTrader: (0)

Modern BMWs have a sensor called Intelligent Battery Sensor (IBS) in the battery lead. It monitors current and detects parasitic draw from e.g. faulty modules, dash cams — and alerts ”increased battery discharge” way before the battery voltage drops. Erratic behaviour of your comfort access could be clue. I’d start troubleshoting with a fault code scan.
Appreciate 0
      01-16-2019, 03:52 PM   #6
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Thanks for the reply’s.

Changed batteries in both my fobs. No change.

I’ll get the car scanned and see if it brings any fault codes up.

Cheers
Appreciate 0
      01-16-2019, 07:23 PM   #7
Rob1910
Enlisted Member
Rob1910's Avatar
Scotland
7
Rep
43
Posts

Drives: BMW i8 Roadster 69
Join Date: Jan 2019
Location: Stirlingshire

iTrader: (0)

Smile Same Issue

Hi Danny

Similar issue here! I got a 640d in December, car had been sitting in dealers for a few weeks before picking it up. Brought car back up the road (200 miles) but unfortunately drove up playing with the toys, stereo on, heated seats on, lights on, fan on, cruise on and wipers on.
Got up the road all ok. Left car a few days and the "Battery discharging when stationary" message appeared and then disappeared after a few miles.

The car was left over Christmas and new year and by that time when I unlocked the lights wouldn't come on so I bought a NOCO Genius 3500 on special from Amazon (£35.00) and charged the battery up (it was showing less than 25%)

Battery now charged beyond 75% I drive 50 mile round trip to work Mon-Fri (car not used apart from that).

BUT...I've left the car over the weekend since charging and I get the message, again briefly, but once driven it clears.

I spoke to my local dealer in Stirling and they've said it's due to the battery not being fully charged and have recommended charging it fully and leaving it over the weekend and see what happens.

The "secret" menu shows 14.6 - 14.8 volts when running and 12.7 as soon as the engine stops. Unfortunately as I work nights when I use the car its lights on, wipers on, fan on and cruise on.

I've a quick query I'm hoping someone can help me with...
When I run the car on Eco-Pro I find over the course of a 50 mile run (work and back) I'm gaining 0.4 miles. But when I use the menu I find battery at power down is 12.4? Is that due to the battery only charging when I brake?

Car back on the NOCO tonight and almost fully charged, will be back on in the morning til fully charged then I'll let you know!!

Danny did the key fob battery change help in any way? I don't have the comfort access.

Thanks and welcome

Rob
Appreciate 0
      01-17-2019, 08:34 AM   #8
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Hi Rob,

Changing the batteries in the Fob had no change. My comfort access works ok sometimes but other times my car unlocks when I’m just near my car and not touching the handle.

I believe my comfort access issue is caused by an issue with my battery or vice versa.

I fully charged my battery, disconnects dthe battery for 2 days and tested it and it was still full however I did stupidly lock myself out my boot as I had read in a Forum thatbthere is a key slot under the rear BMW badge to enable access manually however I didn’t read that it doesn’t exist in the coupe ����

My car has been recalled for the EGR valve and is in the garage next week so getting them to look at it as i have a 1 year warranty.

Will let you know what they say.

Cheers

Dan
Appreciate 0
      01-17-2019, 06:21 PM   #9
Rob1910
Enlisted Member
Rob1910's Avatar
Scotland
7
Rep
43
Posts

Drives: BMW i8 Roadster 69
Join Date: Jan 2019
Location: Stirlingshire

iTrader: (0)

Hi Danny

I'm in for the recall on Fri next week and have mentioned to the dealer about the battery so fingers crossed!
I've charged the car fully tonight as it won't be used from tomorrow morning so hopefully the message disappears but I'll keep you posted!
Appreciate 0
      01-19-2019, 05:52 PM   #10
2dogs2099
New Member
0
Rep
12
Posts

Drives: 640i GC
Join Date: Dec 2018
Location: North Curl Curl, Sydney

iTrader: (0)

Hi all,
I have the same problem with my 2014 GC 640i. Battery discharge alert and clicking comfort access problem. My actuator clicking noise / vibration is coming from fuel cover area. I replaced fob batteries but no difference. Clicking fault is intermittent, comfort access sometimes opens when I'm near even if I've just locked the car and I'm walking off. Sometimes car doesn't want to lock or open.
My X6 before this had comfort access and never had a problem.....
Interested if anyone knows the answer / fix on this as its sounds a common issue.

cheers

2d
Appreciate 0
      01-20-2019, 09:55 AM   #11
elvisisdog
Second Lieutenant
33
Rep
200
Posts

Drives: F06 MSport 2013/09
Join Date: Jan 2017
Location: UK

iTrader: (0)

Like I said, change the key fob battery then wait a few weeks. No idea why it took so long, but comfort access was doing exactly as described. My key fob batteries were definitely low, was getting present key when getting in the car. That was fixed straight away with the key fob battery changed. I'd assumed that the problem was the door handle so took that off to have a look no obvious issue, continued to use the car and comfort access on the passenger side and like I said after 2-3 weeks the clicking stopped and all was working fine. No idea if mine was an intermittent problem, I was very happy it sorted itself out as using the key fob after having got used to comfort access felt very antiquated.
Appreciate 0
      01-20-2019, 12:19 PM   #12
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Hi 2dogs,

Yeah sounds exactly the same as my issue. Not had the battery discharge message for a few days however when I use the secret menu it states battery was at 12.0v. Also sometimes when I use the fob to lock the car(if comfort access isn’t working) it folds the wing mirrors which it has never done.

Definitely puzzled, I’ve replaced the battery in my fob and I’ve noticed I get the present key to steering column a lot more now. Even when I use my spare fob.

Car is in garage on Wednesday for the recall so see what the garage say about the battery.

Will keep you posted.

Cheers

Dan
Appreciate 0
      01-20-2019, 12:20 PM   #13
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Quote:
Originally Posted by elvisisdog View Post
Like I said, change the key fob battery then wait a few weeks. No idea why it took so long, but comfort access was doing exactly as described. My key fob batteries were definitely low, was getting present key when getting in the car. That was fixed straight away with the key fob battery changed. I'd assumed that the problem was the door handle so took that off to have a look no obvious issue, continued to use the car and comfort access on the passenger side and like I said after 2-3 weeks the clicking stopped and all was working fine. No idea if mine was an intermittent problem, I was very happy it sorted itself out as using the key fob after having got used to comfort access felt very antiquated.
Hi Mate,

Yeah Iíve replaced the battery in the fob, no change really, itís very random when it happens etc, will see what the garage say on Wednesday.

Thanks

Dan
Appreciate 0
      01-20-2019, 01:19 PM   #14
Rob1910
Enlisted Member
Rob1910's Avatar
Scotland
7
Rep
43
Posts

Drives: BMW i8 Roadster 69
Join Date: Jan 2019
Location: Stirlingshire

iTrader: (0)

Hi
Well no further on and after less than a month already starting to worry about this 6 series
Charged battery to full on Thurs night, drove 25 miles to work and same again back.
Left car Fri morning voltage showing 12.7 on menu.
Unlocked car tonight no 'welcome' lights on.
Got the battery discharging when stationary message. Battery down to 12.4 on menu.
Stuck it back on charger...I think my neighbours think I've bought an electric car!!!
I don't know what's draining it? It's a 13 plate with 18k on it still on original 90mah Banner battery...shouldn't it be 95mah or 120?
Should I be looking at replacing the battery or are the 640's prone to electrical issues???

The car has been driven with NO air con NO heated seats, Fans on low, screen on and lights/wipers on due to travelling when dark.

Last edited by Rob1910; 01-21-2019 at 07:34 PM..
Appreciate 0
      01-21-2019, 10:46 AM   #15
jjasonSU
First Lieutenant
143
Rep
346
Posts

Drives: 650i, NSX
Join Date: Sep 2018
Location: Dallas

iTrader: (0)

Quote:
Originally Posted by Rob1910 View Post
Hi

I don't know what's draining it? It's a 13 plate with 18k on it still on original 90ah Banner battery...shouldn't it be 95ah or 120?
Should I be looking at replacing the battery or are the 640's lemons???
So the battery is 5 years old? Sounds like its time for a replacement
Appreciate 0
      01-21-2019, 10:48 AM   #16
elvisisdog
Second Lieutenant
33
Rep
200
Posts

Drives: F06 MSport 2013/09
Join Date: Jan 2017
Location: UK

iTrader: (0)

I'd get the battery replaced, not sure the cost but at 5-6 years old with low mileage it may have some problems from lack of use. The car battery in mine had been sound (also 13 plate) currently on 85k mileage, does a lot of short trips to the train station gets left at airports for weeks and with the exception of the key fob battery it's had no issues at all. For the cost of a new battery and some hastle free driving it may bring some enjoyment back into the car for you. I'm looking at reading mine in for a newer version, can't imagine wanting to drive anything else at the moment.
Appreciate 0
      01-21-2019, 11:19 AM   #17
Rob1910
Enlisted Member
Rob1910's Avatar
Scotland
7
Rep
43
Posts

Drives: BMW i8 Roadster 69
Join Date: Jan 2019
Location: Stirlingshire

iTrader: (0)

Spoke to BMW today they still recommend a 90mah battery but euro car parts and Halfords recommend 95 or 105mah so not sure where to go but am thinking new battery could well be the way to go.

Thanks to F06WIN in another thread who has kindly supplied me with BMW's code for the 105mah battery which will fit the car...so fingers crossed and I'll keep you guys posted.

Last edited by Rob1910; 01-21-2019 at 07:32 PM..
Appreciate 0
      01-22-2019, 08:25 PM   #18
Rob1910
Enlisted Member
Rob1910's Avatar
Scotland
7
Rep
43
Posts

Drives: BMW i8 Roadster 69
Join Date: Jan 2019
Location: Stirlingshire

iTrader: (0)

Hi Danny

Good luck for today! Let me know how it goes

Thanks

Rob
Appreciate 0
      01-23-2019, 05:30 AM   #19
2dogs2099
New Member
0
Rep
12
Posts

Drives: 640i GC
Join Date: Dec 2018
Location: North Curl Curl, Sydney

iTrader: (0)

Thanks Dan, I'm putting my bus in the shop. Ill let you know if I have a win. cheers.

2d
Appreciate 0
      01-23-2019, 03:35 PM   #20
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Quick Update,

Garage phoned earlier saying they need to keep my car overnight to charge the battery. Really not convinced that it just needs charged. No update on Comfort access, so will need to wait till tomorrow to hopefully find something out.

Will keep you posted.
Appreciate 0
      01-24-2019, 07:37 AM   #21
Danny396
New Member
1
Rep
21
Posts

Drives: 640d
Join Date: Jan 2019
Location: Scotland

iTrader: (0)

Just had a call from BMW, they are saying my comfort access is causing the drain so they are replacing both door handles and petrol cap lock.

They have had to order them in which will mean another trip to the garage to swap my 6 series for a 1 series manual ������������

On the recall, they didn’t need to replace my EGR valve.

��
Appreciate 0
      01-24-2019, 08:56 AM   #22
Rob1910
Enlisted Member
Rob1910's Avatar
Scotland
7
Rep
43
Posts

Drives: BMW i8 Roadster 69
Join Date: Jan 2019
Location: Stirlingshire

iTrader: (0)

Brill! I think! Egr good, battery drain found...manual 1!?
Mine is winning me over and I think I have been harsh on it
Battery back to full charge when I leave it,drops a little through the night, not enough to trigger the message though.

Will let you know how it goes!
Appreciate 0
Post Reply

Bookmarks

Tags
battery, drain, error, voltage

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:54 AM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST