BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Go Back   6Post.com | BMW 6-Series Forum > BIMMERPOST Universal Forums > General BMW News and Cars Discussion

Post Reply
 
Thread Tools Search this Thread
      02-26-2024, 09:28 AM   #1
dumnyezau
Registered
2
Rep
2
Posts

Drives: F20 125D M-sport Pre-LCI
Join Date: Feb 2024
Location: Bucharest/Romania

iTrader: (0)

F20 125D Pre-LCI engine failure questinon

Hello All,

I`m new to this forum so I want to start by greeting you all and coming to u guys with a question.

I have an F20 125d M-sport 2012 with the engine N47D20D.

The short story was that I was going on the motorway almost full throttle (like 3800-4000RPM) last gear and after 10-12km the acceleration just died and engine started shaking like it would jump out of the car.
I stopped on the motorway and the car had an Drivetrain failure error and proceed to get out of the highway (the car was in limp mode and did not want to accelerate in any way or form like she would).

The thing that made it worst I think, some guy offered to help me out with his laptop in the petrol station I stopped to read my error codes and he accelerated the car and went in Diesel Runaway (revved like crazy and got really thick white smoke coming from the exhaust for like 2 seconds before the car stopped itself.

Did not encounter this before, I got the car at 190 000km and for 50-60k km had no issues with her and tried to have good care of her. Maintenance was done at 8-10k km and so on.

**Verified the turbos/Verified high pressure pump/verified the injectors but they seemed fine.

The issues now is that the car engine is still shaking like crazy, I don t have compression on my cylinders (some have little some have 0) and after the engine starts to heat up, white smoke come from the exhaust like water evaporating and I think that she is also leaking coolant trough the exhaust.

I wanted to know if somebody had this problem before and if yes, how did u resolve it. My mechanic is saying that the engine is dead but I don`t really understand why because it starts like normal, maybe a little slow but starts normally.


Sorry if I did not post this in the correct forum.
Thank u all!
Appreciate 1
DrFerry6725.50
      02-26-2024, 09:31 AM   #2
DrFerry
Field Marshal
DrFerry's Avatar
United_States
6726
Rep
1,833
Posts

Drives: '08 E92 M3
Join Date: Jul 2010
Location: Greenville, SC

iTrader: (5)

Garage List
2008 BMW M3  [5.25]
2015 BMW X5  [4.50]
Quote:
Originally Posted by dumnyezau View Post
Hello All,

I`m new to this forum so I want to start by greeting you all and coming to u guys with a question.

I have an F20 125d M-sport 2012 with the engine N47D20D.

The short story was that I was going on the motorway almost full throttle (like 3800-4000RPM) last gear and after 10-12km the acceleration just died and engine started shaking like it would jump out of the car.
I stopped on the motorway and the car had an Drivetrain failure error and proceed to get out of the highway (the car was in limp mode and did not want to accelerate in any way or form like she would).

The thing that made it worst I think, some guy offered to help me out with his laptop in the petrol station I stopped to read my error codes and he accelerated the car and went in Diesel Runaway (revved like crazy and got really thick white smoke coming from the exhaust for like 2 seconds before the car stopped itself.

Did not encounter this before, I got the car at 190 000km and for 50-60k km had no issues with her and tried to have good care of her. Maintenance was done at 8-10k km and so on.

**Verified the turbos/Verified high pressure pump/verified the injectors but they seemed fine.

The issues now is that the car engine is still shaking like crazy, I don t have compression on my cylinders (some have little some have 0) and after the engine starts to heat up, white smoke come from the exhaust like water evaporating and I think that she is also leaking coolant trough the exhaust.

I wanted to know if somebody had this problem before and if yes, how did u resolve it. My mechanic is saying that the engine is dead but I don`t really understand why because it starts like normal, maybe a little slow but starts normally.


Sorry if I did not post this in the correct forum.
Thank u all!
Could be a failed head gasket. Check and see there is oil in the radiator coolant.
__________________
'08 E92 M3 DCT Melbourne Red/Bamboo Beige Leather/EDC/SSP Spec-R DCT clutch discs/SSP Pro-Gold DCT Fluid/Quaife LSD/3:45 Final Drive by Diffs Online/BE Bearings & ARP Bolts/Vibra Technics Engine Mounts/M3 World HFC X-Pipe/LUX H8 180/BPM Sport DCT Tune/PFC Z-Rated Pads/ECS Brass Brake Caliper Bushings/Alex Shop Solid Sub-frame Bushings/Motul 600/Tint
Appreciate 1
      02-26-2024, 09:40 AM   #3
dumnyezau
Registered
2
Rep
2
Posts

Drives: F20 125D M-sport Pre-LCI
Join Date: Feb 2024
Location: Bucharest/Romania

iTrader: (0)

She had oil in the intake manifold if I remember what my mechanic said when I first gave her to him. I`m currently waiting for him to make a test with comprimate air and see where the damage was done. I suppose he will take a look at the head gasket before taking apart the engine

Thank u for the fast response. I`m still waiting to see if anybody had issues like this and if the problem was only the head gasket or anything else beside this.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:20 PM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST