BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Go Back   6Post.com | BMW 6-Series Forum > BMW 6 Series Forum > BMW M6 Forum (F12 / F13)

Post Reply
 
Thread Tools Search this Thread
      08-20-2022, 11:26 AM   #1
LeonBisha
New Member
0
Rep
10
Posts

Drives: F12 M6
Join Date: Dec 2019
Location: London

iTrader: (0)

M6 2016 Blown Engine, Rebuilt and issues after issues with air pressure!

Hi everyone sorry in advance for my horrible bad experience my M6 Cabrio 2016 30k miles seized up a few months back!

I tried to get used warranty and sent it to bmw and they refused it due to computer picked up a Remap a while back apparently so they said!

After alot of running around, managed to source a garage that wpuld help me rebuilt my engine and we would fit same engine but with Forged Rods instead of standard Rods! So here is my journey fitting engine :-)

Bought a new crank from BMW and to facilitate for the Forged Rods, had the crank precision adjusted weight!

Started putting everything back together, new crank, rods, and all small bits that go with it, inc new gaskets of course, Did not change the pistons, kept the original ones!

Slowly mechanic guy including myself we started putting engine together, double checking every bolt,screw,clip and we did double check and to our knowledge everything is as it should!

We fitted all 8 new injectors including all new spark plugs and coil packs!

So the moment of truth comes, we start the car and it runs a bit rough on cold start, Bear in mind car is now stock with no remap and cold start active BUT we do have OEM Downpipes Gutted!

Once car is warmed it seems to be running nice when driving, when on idle it does run a bit rough and car sort of shakes a bit!

So went ahead put back remap, catd deleted, cold start deactivated… still rough cold start and rough idle running even when warm!

Plugged computer and only get one error code:

102002: Air Mass, Plausibility: Air Mass To Low

Did smoke test— no leaks

Swapped MAF’s other way around — no change

Swapped MAF’s completely — no change

Tuner says you have air leak…
Mechanic smoke checked and we put engine together and no smoke leak!

Its been so frustrating and time consuming, and realy cant seem to get a break!

Really hoping someone had same/ similar experiences and can share more info!

Once again apologies for the long essay :-)
Appreciate 0
      08-20-2022, 12:46 PM   #2
M6Roar
Second Lieutenant
86
Rep
242
Posts

Drives: '14 M6GC
Join Date: Apr 2018
Location: Bahrain

iTrader: (0)

I had the same issue, I popped my intake manifold.
https://www.6post.com/forums/showthr...1914829&page=2
Appreciate 0
      08-20-2022, 01:15 PM   #3
LeonBisha
New Member
0
Rep
10
Posts

Drives: F12 M6
Join Date: Dec 2019
Location: London

iTrader: (0)

Quote:
Originally Posted by M6Roar View Post
I had the same issue, I popped my intake manifold.
https://www.6post.com/forums/showthr...1914829&page=2
Thank you very much for your reply, We did double check everything and we did even smoke test but didnt get any leaks, will re check again!

One thing for sure this roughness is only apparent when cold start (worse) and on idling… once the car is above 2000 rpm it runs bloody smooth!
Appreciate 0
      08-20-2022, 09:14 PM   #4
M6Roar
Second Lieutenant
86
Rep
242
Posts

Drives: '14 M6GC
Join Date: Apr 2018
Location: Bahrain

iTrader: (0)

Make a datalog and we might figure it out. I actuated the throttle and blocked the PCV going to the intake to get the smoke into the intake manifold.
Appreciate 0
      08-21-2022, 11:39 AM   #5
OnlyGerman
Major
OnlyGerman's Avatar
United_States
362
Rep
1,260
Posts

Drives: F15, F13, F10, E60
Join Date: Jul 2019
Location: Sunshine State

iTrader: (0)

Who reported the tune to warranty? The dealer or did they sent a inspector?
Appreciate 0
      08-21-2022, 12:55 PM   #6
LeonBisha
New Member
0
Rep
10
Posts

Drives: F12 M6
Join Date: Dec 2019
Location: London

iTrader: (0)

Well car went inn and all dealer told me was that there was ecu modifications at some point but were not present.. the dealer told me if we sent to warranty they will refuse it instantly!

I was also told since June 2020 bmw has implemented a system called Pop Up which automatically scans your car and send live data to BMW…
Appreciate 0
      08-27-2022, 12:18 PM   #7
danielgmanm6
Private First Class
danielgmanm6's Avatar
United_States
87
Rep
179
Posts

Drives: 2013 BMW ///M6 F13
Join Date: May 2022
Location: Raleigh Nc

iTrader: (0)

Garage List
2013 Bmw M6  [0.00]
  [0.00]
  [0.00]
[QUOTE=LeonBisha;29243508]Hi everyone sorry in advance for my horrible bad experience my M6 Cabrio 2016 30k miles seized up a few months back!

I tried to get used warranty and sent it to bmw and they refused it due to computer picked up a Remap a while back apparently so they said!

After alot of running around, managed to source a garage that wpuld help me rebuilt my engine and we would fit same engine but with Forged Rods instead of standard Rods! So here is my journey fitting engine :-)

Bought a new crank from BMW and to facilitate for the Forged Rods, had the crank precision adjusted weight!

Started putting everything back together, new crank, rods, and all small bits that go with it, inc new gaskets of course, Did not change the pistons, kept the original ones!

Slowly mechanic guy including myself we started putting engine together, double checking every bolt,screw,clip and we did double check and to our knowledge everything is as it should!

We fitted all 8 new injectors including all new spark plugs and coil packs!

So the moment of truth comes, we start the car and it runs a bit rough on cold start, Bear in mind car is now stock with no remap and cold start active BUT we do have OEM Downpipes Gutted!

Once car is warmed it seems to be running nice when driving, when on idle it does run a bit rough and car sort of shakes a bit!

So went ahead put back remap, catd deleted, cold start deactivated… still rough cold start and rough idle running even when warm!

Plugged computer and only get one error code:

102002: Air Mass, Plausibility: Air Mass To Low

Did smoke test— no leaks

Swapped MAF’s other way around — no change

Swapped MAF’s completely — no change

Tuner says you have air leak…
Mechanic smoke checked and we put engine together and no smoke leak!

Its been so frustrating and time consuming, and realy cant seem to get a break!

Really hoping someone had same/ similar experiences and can share more info!

Once again apologies for the long essay :-)[/QUOTE



Holy exclamation points batman
Appreciate 0
      08-28-2022, 02:11 AM   #8
Mirza_7
Private First Class
Mirza_7's Avatar
United_States
76
Rep
104
Posts

Drives: X6-GO6, M6-F13
Join Date: Oct 2021
Location: Nassau, New York

iTrader: (0)

So this issue wasn't on my M6.. but on my GTR kept getting "air mass to low" CELs and I couldn't find a leak anywhere. (This was after beating on the car all summer).

Tuner suggested new fuel pumps and that actually fixed my issue (they were already aftermarket).

Not sure if there's a way to 'test' the HPFP's but worth asking someone who would know.
Appreciate 0
      09-09-2022, 06:22 AM   #9
LeonBisha
New Member
0
Rep
10
Posts

Drives: F12 M6
Join Date: Dec 2019
Location: London

iTrader: (0)

So
An update, did smoke test and no leaks anywhere… update the car to latest softjust in case and no difference…. Opened engine again and fitted two new valvtronic valves and still no change….

The annoying thing is when I disconnect the crank shaft sensor the car runs smooth but it goes into emergency mode!

When everything connected the roughness on idle comes back on, and smell of fuel is quiet noticeably…

Still trying to find the issue :-(
Appreciate 0
      12-29-2022, 02:23 PM   #10
JibHonk
Private First Class
69
Rep
165
Posts

Drives: 15 m235i
Join Date: May 2015
Location: NEPA

iTrader: (0)

Timing is off. Recheck chains. Recheck cams.
Appreciate 0
      12-30-2022, 02:09 AM   #11
M3talllic
Second Lieutenant
M3talllic's Avatar
United_States
35
Rep
244
Posts

Drives: M3 E92 & M6 GC
Join Date: Jul 2017
Location: Corona, CA

iTrader: (0)

Garage List
I had an issue similar to this. Swapped my HPFP and voila!
It was covered under warranty for 10 years or 100k, or 120k (don’t recall exactly), apparently S63s have a known issue with HPFPs
Appreciate 0
      03-17-2023, 03:52 AM   #12
Msparta
First Lieutenant
312
Rep
305
Posts

Drives: X6M
Join Date: Jul 2013
Location: -

iTrader: (0)

Humm sometimes the issue can be as simple and paying close attention to the MAF connector and clip… these two connectors get brittle and temperamental after many years of engine heat and when unplugged and replugged…

It happened to me and led me down an expensive list of parts that at the end were not needed… the issue for me was ensuring these plugs were seated perfectly and secured then locked with their little clip…

On a side note - engine rebuilds and breakin procedure is very strict…
Appreciate 0
Post Reply

Bookmarks

Tags
bmw m6

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:21 AM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST