BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Go Back   6Post.com | BMW 6-Series Forum > BMW 6 Series Forum > BMW M6 Forum (F12 / F13)

Post Reply
 
Thread Tools Search this Thread
      11-14-2021, 05:28 PM   #1
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

New issue after speeding

So Iíve had a check engine light on since I bought the car. Figured it was o2 sensor from codes and the look of it.

Well replaced the o2 sensor yesterday and everything was perfectly fine and the car continued driving great.

Now today I found a cls63s on the highway and he wanted to have some fun. Of course I went at it with him right to about 160.

2 minutes later as I was driving normally again, the drivetrain malfunction pops on. I ran codes with my bootmod3 app and nothing. Cleared it and it just pops on after and acceleration. So essentially while driving I can clear the code and soon as I touch the throttle, drivetrain and cel pops on again.

Any ideas? Not sure what could have gone wrong from driving that fast. I drive back on the highway slowly as the drive train warning shuts down a lot of engine power so you donít toast the engine.

Should I order a better bmw scanner rather than just the app? I was able to pull the o2 sensor codes with it prior with no issue. Going to go unplug the ground for an hour right now and see if that helps.

Thanks guys.
Appreciate 0
      11-15-2021, 03:21 AM   #2
MelbourneFinn
Second Lieutenant
MelbourneFinn's Avatar
Australia
109
Rep
239
Posts

Drives: 2017 M6 GC
Join Date: Dec 2017
Location: Melbourne, Australia

iTrader: (0)

Garage List
Hmm, didn't come to think that there might actually be a reason (like something wrong), not only an annoying warning light that goes away with a couple of clicks?
Appreciate 0
      11-15-2021, 08:36 AM   #3
Kick 6
Private
Kick 6's Avatar
158
Rep
80
Posts

Drives: BMW M6
Join Date: Apr 2021
Location: Georgia

iTrader: (0)

Did you beat him?
Appreciate 2
MNhv56.50
JDMSteven270.50
      11-15-2021, 09:56 AM   #4
HeyKC
Private First Class
United_States
67
Rep
160
Posts

Drives: BMW M6 CP
Join Date: Jun 2019
Location: KCMO

iTrader: (0)

Plugs & coils...
Appreciate 0
      11-15-2021, 01:17 PM   #5
TinCanSailor
Fueled by Recycled Dinosaurs!
TinCanSailor's Avatar
United_States
187
Rep
556
Posts

Drives: F06 M6
Join Date: Dec 2019
Location: 813Bay, Fl

iTrader: (2)

Garage List
Quote:
Originally Posted by HeyKC View Post
Plugs & coils...
+1 or maybe the MAF's
__________________
2015 M6 Gran Coupe (Mine) Silverstone Metallic II, Indiv. Full Leather (Cohiba), B&O, Night Vision, Carbon Ceramic Brakes, @rkautowerks Carbon Fiber CAI, @rkautowerks Billet Differential Brace ...
2013 550i M Sport (Mrs') B&O
Appreciate 0
      11-15-2021, 01:42 PM   #6
LJohnson32
First Lieutenant
LJohnson32's Avatar
United_States
171
Rep
330
Posts

Drives: 2016 BMW M6 Gran Coupe
Join Date: Mar 2020
Location: Minnesota

iTrader: (1)

Quote:
Originally Posted by HeyKC View Post
Plugs & coils...
+1
__________________
Appreciate 0
      11-15-2021, 02:33 PM   #7
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

Quote:
Originally Posted by HeyKC View Post
Plugs & coils...
Got it thank you Iíll give those a look. Just wish I could get a damn code. Ordered a new code reader off Amazon to give it a go.

After restoring to stock tune, check engine is off but car def feels and sounds off still as well as a noise from the front when idling.
Appreciate 0
      11-15-2021, 02:49 PM   #8
Kick 6
Private
Kick 6's Avatar
158
Rep
80
Posts

Drives: BMW M6
Join Date: Apr 2021
Location: Georgia

iTrader: (0)

Quote:
Originally Posted by deni2316 View Post
Got it thank you Iíll give those a look. Just wish I could get a damn code. Ordered a new code reader off Amazon to give it a go.

After restoring to stock tune, check engine is off but car def feels and sounds off still as well as a noise from the front when idling.
But did you win the race?
Appreciate 0
      11-15-2021, 03:09 PM   #9
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

Quote:
Originally Posted by Kick 6 View Post
But did you win the race?
Yea lol he was stock considering it was dealer plates on the car.
Appreciate 1
HeyKC66.50
      11-16-2021, 06:46 AM   #10
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

So now check engine light wonít turn back on after going to stock. New reader not giving me anything either. Any way to force the code on?

Itís definitely either plugs or coils based on symptoms
Appreciate 0
      11-16-2021, 09:03 AM   #11
HeyKC
Private First Class
United_States
67
Rep
160
Posts

Drives: BMW M6 CP
Join Date: Jun 2019
Location: KCMO

iTrader: (0)

Quote:
Originally Posted by deni2316 View Post
So now check engine light wonít turn back on after going to stock. New reader not giving me anything either. Any way to force the code on?

Itís definitely either plugs or coils based on symptoms
If you have a fancy enough scanner you can look up stored codes. If you plan to run any tune I would just go ahead and order new plugs(NGK 97506) and gap them to .020.

Rockauto seems to have the best prices.
Appreciate 0
      11-16-2021, 11:42 AM   #12
TinCanSailor
Fueled by Recycled Dinosaurs!
TinCanSailor's Avatar
United_States
187
Rep
556
Posts

Drives: F06 M6
Join Date: Dec 2019
Location: 813Bay, Fl

iTrader: (2)

Garage List
I got my plugs from https://burgertuning.com/ They sell a kit with a thin walled socket that you'll wish you had when you get things apart and figure out that your sockets don't fit too well in there. They also have a nice gapping tool if you plan on running tunes you will likely need to re-gap the plugs. It very well could be that the prev owner had tuned the car and gapped the plugs for the increased boost.
__________________
2015 M6 Gran Coupe (Mine) Silverstone Metallic II, Indiv. Full Leather (Cohiba), B&O, Night Vision, Carbon Ceramic Brakes, @rkautowerks Carbon Fiber CAI, @rkautowerks Billet Differential Brace ...
2013 550i M Sport (Mrs') B&O
Appreciate 0
      11-16-2021, 01:12 PM   #13
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

For the ignition coils, any you guys particularly recommend?
Appreciate 0
      11-16-2021, 02:01 PM   #14
TinCanSailor
Fueled by Recycled Dinosaurs!
TinCanSailor's Avatar
United_States
187
Rep
556
Posts

Drives: F06 M6
Join Date: Dec 2019
Location: 813Bay, Fl

iTrader: (2)

Garage List
Stick with the OEM and get them from fcpeuro for the lifetime warranty.
__________________
2015 M6 Gran Coupe (Mine) Silverstone Metallic II, Indiv. Full Leather (Cohiba), B&O, Night Vision, Carbon Ceramic Brakes, @rkautowerks Carbon Fiber CAI, @rkautowerks Billet Differential Brace ...
2013 550i M Sport (Mrs') B&O
Appreciate 0
      11-18-2021, 01:07 PM   #15
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

Finally got a code, generic misfire on cylinder 2.

Nonetheless spark plugs came in today and coils are in Monday. Replacing all 8 and will update then
Appreciate 1
      11-25-2021, 08:01 PM   #16
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

So all 8 replaced, no check engine, no shaking, 1 of the plugs was completely bad so that solved that.

However after putting everything back, I got a P0174 system too lean bank 2 code. No check engine light.

On first run did still feel a bit underpowered but Iíll give it a go on the highway shortly and see. Not sure how this could be popping on now soon as the car is turned on.
Appreciate 0
      11-25-2021, 10:38 PM   #17
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

So after highway driving for about an hour now.

Got multiple misfire codes and misfire on cylinder 1 and 4 as opposed to cylinder 2.

New plugs are step 2 colder ngk and ignition coils are Delphine.

Now Iím thinking either the ignition coils I bought are bad or is it possible itís the battery? Do the step 2 ones require more voltage? I scanned the voltage and itís around 12.4 off and 13.9 running which is on the low end from what I understand
Appreciate 0
      11-25-2021, 11:19 PM   #18
TinCanSailor
Fueled by Recycled Dinosaurs!
TinCanSailor's Avatar
United_States
187
Rep
556
Posts

Drives: F06 M6
Join Date: Dec 2019
Location: 813Bay, Fl

iTrader: (2)

Garage List
Colder plugs are generally used when tuning adding boost, playing with A/F etc. Spark plugs are highly conductive by design so there is little to no relationship to the amount of electricity needed for firing. I would make sure that all your grounds are clean and tight and that connectors don't have any corrosion in them. The article below is a very informative guide on plugs in general but will explain a lot about coder/hotter use cases. With the P0174 you may be getting unmetered air in after the MAF's or your MAF's may be dirty or bad. I'd check for cracks in the intake plenum and make sure everything is sealed properly. If you haven't replaced the MAF's consider buying new ones or try some MAF cleaner. If this thing had a CAI there is good chance they got dirtied with oil from the air filter.

https://ngksparkplugs.com/en/resourc...rk-plug-basics
__________________
2015 M6 Gran Coupe (Mine) Silverstone Metallic II, Indiv. Full Leather (Cohiba), B&O, Night Vision, Carbon Ceramic Brakes, @rkautowerks Carbon Fiber CAI, @rkautowerks Billet Differential Brace ...
2013 550i M Sport (Mrs') B&O
Appreciate 0
      11-26-2021, 10:38 AM   #19
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

Quote:
Originally Posted by TinCanSailor View Post
Colder plugs are generally used when tuning adding boost, playing with A/F etc. Spark plugs are highly conductive by design so there is little to no relationship to the amount of electricity needed for firing. I would make sure that all your grounds are clean and tight and that connectors don't have any corrosion in them. The article below is a very informative guide on plugs in general but will explain a lot about coder/hotter use cases. With the P0174 you may be getting unmetered air in after the MAF's or your MAF's may be dirty or bad. I'd check for cracks in the intake plenum and make sure everything is sealed properly. If you haven't replaced the MAF's consider buying new ones or try some MAF cleaner. If this thing had a CAI there is good chance they got dirtied with oil from the air filter.

https://ngksparkplugs.com/en/resourc...rk-plug-basics

Cleaning/replacing MAFs will be next step. Just a weird occurrence to get all these codes now after replacing plugs and coils that werenít on before. And all this only started after the original speeding and blown plugs.

To think now all of the sudden itís maf or something more that wasnít on before just strikes me as odd. My dad is coming back up here tomorrow to take a look at everything again so Iíll keep this updated.

He did check for leaks yesterday after replacing everything and there were none to be detected on the engine bay.
Appreciate 0
      11-26-2021, 11:06 AM   #20
TinCanSailor
Fueled by Recycled Dinosaurs!
TinCanSailor's Avatar
United_States
187
Rep
556
Posts

Drives: F06 M6
Join Date: Dec 2019
Location: 813Bay, Fl

iTrader: (2)

Garage List
You need 4 things to make fire; oxygen, fuel, heat and the chemical reaction. Improperly measure or take away any one of those and you don't have fire or ya get a fire that is out of control.

Although it seems weird/unusual to have this condition present itself; keep in mind that you have also changed the conditions which the air/fuel burns. Where before a fouled plug may not have burned all the fuel and appeared richer to the sensors, now you have clean plugs and new coils that will make light work of this now.

If it isn't the MAF's and you are 100% sure the 02 sensors are good then your next stop may be to have a compression test done o the engine or just go ahead and have the injectors replaced. If one or more is not spraying properly you stand the chance of doing significant damage to the engine so I'd try to refrain from really getting into the throttle until you have this sorted.

Also, check down around the throttle bodies. If the PO had charge coolers or did cooling system work there is a good chance the seals around the throttle body might be not be properly secured.
__________________
2015 M6 Gran Coupe (Mine) Silverstone Metallic II, Indiv. Full Leather (Cohiba), B&O, Night Vision, Carbon Ceramic Brakes, @rkautowerks Carbon Fiber CAI, @rkautowerks Billet Differential Brace ...
2013 550i M Sport (Mrs') B&O
Appreciate 0
      11-26-2021, 11:18 AM   #21
TinCanSailor
Fueled by Recycled Dinosaurs!
TinCanSailor's Avatar
United_States
187
Rep
556
Posts

Drives: F06 M6
Join Date: Dec 2019
Location: 813Bay, Fl

iTrader: (2)

Garage List
Have this this guide https://www.6post.com/forums/showthread.php?t=803495 and the websites newtis.info and https://realoem.com/ handy as you are troubleshooting. If you don't have a tool that you can scan and data log to or a windows computer with ISTA; I'd suggest taking the car to a reputable bmw/euro indy repair shop to pay for the diag.
__________________
2015 M6 Gran Coupe (Mine) Silverstone Metallic II, Indiv. Full Leather (Cohiba), B&O, Night Vision, Carbon Ceramic Brakes, @rkautowerks Carbon Fiber CAI, @rkautowerks Billet Differential Brace ...
2013 550i M Sport (Mrs') B&O
Appreciate 0
      11-26-2021, 01:48 PM   #22
deni2316
New Member
6
Rep
28
Posts

Drives: bmw m6 gran coupe
Join Date: Oct 2021
Location: Tampa, Florida

iTrader: (0)

Quote:
Originally Posted by TinCanSailor View Post
Have this this guide https://www.6post.com/forums/showthread.php?t=803495 and the websites newtis.info and https://realoem.com/ handy as you are troubleshooting. If you don't have a tool that you can scan and data log to or a windows computer with ISTA; I'd suggest taking the car to a reputable bmw/euro indy repair shop to pay for the diag.
I bought the newest AUTOPHIX tool for bmw so it shows everything across all modules

Any idea why when I switch to stock maps with bom3 and relocate dme, I donít get any codes at all but car is still feeling underpowered/lack of throttle response
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:19 PM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST