BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
      06-01-2021, 12:24 PM   #1
ppasiakos
Enlisted Member
17
Rep
47
Posts

Drives: BMW M6 Convertible
Join Date: Nov 2020
Location: Phoenix AZ

iTrader: (0)

Speedo Error

I was driving my car the other day and everything seemed normal until the last few miles getting home. I was in 3rd gear going around 50 according to my HUD and digital dash. The speedometer showed me doing around 130mph. So when I came to a stop the speedo went down to 60mph and stopped. The car is currently sitting in the garage and still reading 60mph. Any ideas on what this may be? And how to correct it? I am tired of bringing it in to the dealership.
Appreciate 0
      06-01-2021, 04:42 PM   #2
Whipple
Lieutenant
Whipple's Avatar
218
Rep
537
Posts

Drives: 2015 BMW M6 Gran Coupe
Join Date: Jun 2011
Location: New York

iTrader: (0)

Thatís weird, The only thing I can suggest is take the negative off the battery for 10 mins , this might reset the problem, unless there is something mechanically wrong with your cluster
Appreciate 0
      06-01-2021, 10:14 PM   #3
ppasiakos
Enlisted Member
17
Rep
47
Posts

Drives: BMW M6 Convertible
Join Date: Nov 2020
Location: Phoenix AZ

iTrader: (0)

Pulled the negative terminal. Waited 10 minutes. All seems back to normal.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:39 AM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST