BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Go Back   6Post.com | BMW 6-Series Forum > BMW 6 Series Forum > BMW M6 Forum (F12 / F13)

Post Reply
 
Thread Tools Search this Thread
      03-03-2021, 06:18 PM   #1
Harnoor1234
New Member
0
Rep
9
Posts

Drives: BMW m6 f12
Join Date: Oct 2020
Location: Battle Creek, MI

iTrader: (0)

Mechatronic Replacement at 40k Miles?

Has anyone heard of a mechatronic unit going bad at 43k miles? I have a 2014 bmw m6 GC. ISTA-P stating mechatronic failure but I've been told many times that it is probably something else going on with the car. What else could be the issue causing the diagnostic tool to say the mechatronic is the issue?
Appreciate 0
      03-03-2021, 11:13 PM   #2
eagmail
Private First Class
12
Rep
135
Posts

Drives: 2014 M6
Join Date: Oct 2018
Location: Miami

iTrader: (0)

Quote:
Originally Posted by Harnoor1234 View Post
Has anyone heard of a mechatronic unit going bad at 43k miles? I have a 2014 bmw m6 GC. ISTA-P stating mechatronic failure but I've been told many times that it is probably something else going on with the car. What else could be the issue causing the diagnostic tool to say the mechatronic is the issue?
Had this same issue had line leak and low fluid.
Computer will point to mech failure or solenoids what isshes are you having?
Appreciate 0
      03-04-2021, 12:00 PM   #3
Harnoor1234
New Member
0
Rep
9
Posts

Drives: BMW m6 f12
Join Date: Oct 2020
Location: Battle Creek, MI

iTrader: (0)

I got the clutches replaced and have the transmission shipped to SSP performance. After I got back I got the transmission put back in and did the adoptions. After the adoptions they were driving it in the car went into limp mode. Then when they diagnosed it it said it was a mechatronic issue
Appreciate 0
      03-04-2021, 12:18 PM   #4
eagmail
Private First Class
12
Rep
135
Posts

Drives: 2014 M6
Join Date: Oct 2018
Location: Miami

iTrader: (0)

Was it fine before ?

Have you checked for any leaks etc?
Appreciate 0
      03-04-2021, 01:24 PM   #5
Harnoor1234
New Member
0
Rep
9
Posts

Drives: BMW m6 f12
Join Date: Oct 2020
Location: Battle Creek, MI

iTrader: (0)

So the reason I got the new clutches was because I was driving and I got a drive train malfunction. The car would not go into reverse or first gear. The dealership told me I need new clutches. Thatís when I made the decision to go with aftermarket. So after the clutches got put in everything was fine I tonight but when they drove it it went into limp mode and I got a mechatronics malfunction. They did fix a leak in the transmission pan
Appreciate 0
      03-05-2021, 01:38 AM   #6
Spacecpe
First Lieutenant
Canada
38
Rep
346
Posts

Drives: E90 335i Msport
Join Date: Sep 2014
Location: Winnipeg, Mb Canada

iTrader: (0)

I've heard that the car can throw mechatronics codes if you have a leak somewhere and or the fluid level is low
Appreciate 0
      03-05-2021, 02:56 AM   #7
eagmail
Private First Class
12
Rep
135
Posts

Drives: 2014 M6
Join Date: Oct 2018
Location: Miami

iTrader: (0)

I had the same exact issue had a leak.

Was the car topped off before clutches? I would of checked that first but you did clutches anyway.

Iím quessing itís filled all the way up now.
Appreciate 0
      03-15-2021, 10:39 PM   #8
Harnoor1234
New Member
0
Rep
9
Posts

Drives: BMW m6 f12
Join Date: Oct 2020
Location: Battle Creek, MI

iTrader: (0)

So im getting clutch pressure too high code and ISTA is saying replace mechatronic 40d408
Appreciate 0
Post Reply

Bookmarks

Tags
limp mode, mechatronic, mechatronics, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:29 AM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST