BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Go Back   6Post.com | BMW 6-Series Forum > BMW 6 Series Forum > General 6-Series Coupe, Convertible, and Gran Coupe Forum

Post Reply
 
Thread Tools Search this Thread
      08-29-2019, 10:15 PM   #1
mmakabeh
New Member
0
Rep
6
Posts

Drives: 2010 BMW 650i
Join Date: Aug 2019
Location: Los Angeles, CA

iTrader: (0)

Exclamation 2010 BMW 650i E63 Trans Malfunction DBC 155K miles

Hi everyone! I've had a couple problems with my car. I REALLY love my car and do not want to get rid of it.

First : sometimes when I'm driving the transmission malfunction light comes on and the car slows down to 40 mph. IIt will not drive any faster or change gears. Sometimes pulling off to the side of the road, shutting it off then turning it on again works but most of the time once I shut it off it takes 5-10 to get it go start again. The car does not start and I have to keep jugging it till the car finally starts again. Sometimes the transmission light goes away but mostly it'll stay on for about 2 days. The DBC malfunction light comes on too.
Second: it's been a few times that feels like the car is going to shut off or no fuel for 1 or 2 seconds, but it continues to drive a little rough. Also couple times i went over a bump and all fail lights came on ;
Malfunction in Transmission
DBC Malfunction!
Drive control System
Star-off assistance inactive!
Third: lately when I start the car a ton of white smoke comes out of the exhaust. Smells like burning oil, but I'm really not sure sometimes blue.
Please help ..
mmakabeh@gmail.com
Appreciate 0
      08-31-2019, 01:58 PM   #2
mmakabeh
New Member
0
Rep
6
Posts

Drives: 2010 BMW 650i
Join Date: Aug 2019
Location: Los Angeles, CA

iTrader: (0)

Never did valve stems however..
This is the story..

I started having the Malfunction Transmissions failure code last year .

the car would crank but would not start like no gas.

After several tries it would start and run great.

I Took my car to a Trans Shop he serviced it and programmed it. ( I hope he told me the truth that he did the job)

The car ran well for many months ..

The problems started again this year a couple months ago all fail codes showed up.

My friend who is a BMW mechanic read and reset the fail codes several times and concluded the failures were correct .

Last month he replaced all Camshaft gears, Vanus solenoids chain tensioners, oil, coolant , etc,,, all needed gaskets and seals.

BTW my car has 155K miles.

Battery was replaced 2 weeks ago.

when the car is cold in the morning it runs like brand new.

However after driving 30 min or so or if i drive and park the car, sometimes it would not start and the car shows up with similar issues and failure codes.

And puts the transmission in safety mode of 20-40 Miles. It won't change gears and won't allow Cruise control (gives the code- Cruise Control Failure)

Also a few days i drove over a bump and all fail lights including key and trans and DBC , etc... all fail codes showed up. But went away after driving a little.

This is my story..

I believe there is a board or connection issue like short or possibly grounding issue .

Best,

Michael
Appreciate 0
Post Reply

Bookmarks

Tags
650i, dbc, e63, malfunction, smoke, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:55 AM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST