BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
      05-18-2019, 06:58 PM   #1
Dng93
Enlisted Member
7
Rep
43
Posts

Drives: F13 m6
Join Date: Jun 2016
Location: Sgv

iTrader: (1)

White smoke

had a big cloud of white smoke that looks like it came out of my exhaust at a red light. I pulled over at the next light and there was no smoke from exhaust. Everything seemed fine so I hopped on the highway to do a few hard pulls, no power loss car feels normal. Been 2 days car is fine with no smoke from exhaust.

2013 m6 with 48k miles. Had catless downpipes installed 5k miles ago with a resonator delete

Has anyone experienced something similar to this? Should I be worried ?
Appreciate 0
      05-19-2019, 02:29 AM   #2
Jasoneo5
Second Lieutenant
31
Rep
267
Posts

Drives: M6 Gran Coupe, Turbo S, GS-F
Join Date: Dec 2013
Location: SF Bay area

iTrader: (1)

I've had the same thing happen a few random times. Unsure. Heard it could be turbo seals.

https://f10.m5post.com/forums/showthread.php?t=1611735
Appreciate 1
Dng936.50

      05-19-2019, 03:11 PM   #3
Dng93
Enlisted Member
7
Rep
43
Posts

Drives: F13 m6
Join Date: Jun 2016
Location: Sgv

iTrader: (1)

Quote:
Originally Posted by Jasoneo5 View Post
I've had the same thing happen a few random times. Unsure. Heard it could be turbo seals.

https://f10.m5post.com/forums/showthread.php?t=1611735
Thanks for response. Same thing as Mr.M6 I was switching from sport plus to Efficient mode when it happened.
Appreciate 0
      Yesterday, 03:27 PM   #4
AustinM6
Registered
0
Rep
1
Posts

Drives: BMW M6
Join Date: Sep 2020
Location: Philly

iTrader: (0)

I just purchased a 2016 M6 competition edition. Iím having the same issues with smoking when I come to a stop I brought it to the dealer twice now and they told me they canít find any issues with it... I have come across a few posts were some say itís not an issue, some say itís a turbo seal, and others saying outright piston and or ring failure. I canít see how the smoke would appear from a piston or ring issue when decelerating I would think the issue would get worseUnder load. Has anybody actually having the issue figured it out? To be honest Iím thinking about getting rid of it already I just donít wanna have a major issue down the road
Appreciate 0
      Yesterday, 08:30 PM   #5
MetZF82
Private First Class
48
Rep
142
Posts

Drives: 2015 F06 M6
Join Date: Jun 2015
Location: New York

iTrader: (0)

I actually was behind a M6 coupe the other day. He floored it seeing me behind him and he left a huge cloud of white smoke.

I know the dude and I think that might be the first he ever punched the gas on that car. Maybe they just need to open those lungs up a little 🤪
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:03 PM.




6post.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST