Thread: Yard freaks
View Single Post
      08-29-2020, 08:10 AM   #1023
spazzyfry123
Lieutenant Colonel
spazzyfry123's Avatar
United_States
2082
Rep
1,675
Posts

Drives: Land Cruiser
Join Date: Jul 2013
Location: Florida

iTrader: (1)

Garage List
2011 BMW E90 M3  [5.00]
So I've been doing a lot of work trying to restore the yard from the previous owners for about 6 months and have been feeling pretty good and pleased with the work I've put into it. I was traveling for about 2.5 weeks and couldn't tend to the yard. Typically keep it at about 3".

Well, during that time we got a ton of rain and humidity with high temps. Had some spots at about 8" (!!). Well, turns out I've got some type of fungus I didn't know when I started cutting and proceeded to spread it to my entire yard since I don't bag this time of year.

I was thinking Gray Leaf, but I'm not really seeing any spots on the blades. The blades are a mixture of a hazy yellow, purple, brown, and gray. It. Looks. Like. Hell.

I also saw a few of these almost foamy looking pods around the yard.

Anyone have any ideas on what this is? I stopped by the local extension office for UF's horticulture department and spoke with a guy that was super helpful. Going to work with him to get things resolved as well as soil testing. Of course I didn't have any pictures, and it was all conversation, but do you guys think this can be handled with a Home Depot run with a generic fungicide? Pictures are a "before" from just a few weeks ago to this morning.
Attached Images