BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
      01-26-2014, 01:29 PM   #1
New Member
tony1's Avatar

Drives: 2014 M6 Gran Coupe
Join Date: Nov 2013
Location: Virginia

iTrader: (0)

loss of acceleration

     Featured on
I have installed gruppe M intakes but been having a problem with loss of acceleration when rpms fall below 2000 especially when trying to accelerate in 5th gear or above....Has any had this problem or any thoughts. BMW states mass air flow sensors ok but i am still worried....appreciate any insight
Appreciate 0
      01-26-2014, 10:34 PM   #2
///M Fan

Drives: M6 F13, Alpina B7, X5M F85
Join Date: Jul 2012
Location: Orchard Lake, Mi

iTrader: (0)

Make sure all connections tight. It uses stock mass air flow sensors so that shouldn't be issue. They reuse the factory ones.
2013 BMW Alpina B7x SWB Alpina Blue, Dinantronics Stage 2 600hp, 612lb/ft
2013 BMW M6 Coupe Brilliant White Met. Akrapovic Evo full titanium, AMS Alpha DPs, Gruppe M intake, HRE S101s 20s, full BMW M perf parts, comp springs sway bars, Dinantronics Stage 2, 713hp 651lb/ft
2016 BMW X5M Long Beach Blue, M Perf parts, RKP diffuser (picked up 9-10)
Appreciate 0
Post Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:42 AM.
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.,,,,,,,,, logo and trademark are properties of BIMMERPOST