BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
      11-17-2012, 02:04 AM   #1
andreo
3
BMW Enthusiast
 
andreo's Avatar
 
Drives: Citrin Black 650i Coupé (F13)
Join Date: Jul 2012
Location: Macau

Posts: 352
iTrader: (0)

iPhone and Snap-in Media Adapter

Has any of you experienced your iPhone not enabled at car startup? I have an iPhone 4S attached to a Media Snap-in Adapter and intermittently, it is shown as disabled on the iDrive under External Devices. I need to pop the adapter up and reinsert before the iPhone gets recognized. Very odd.
andreo is offline   Macao
Appreciate 0
Reply With Quote
      11-17-2012, 08:55 AM   #2
M6-4KIX
2
Second Lieutenant
 
Drives: 2012 6 M(pkg) Coupe
Join Date: Oct 2011
Location: Vancouver BC Canada

Posts: 234
iTrader: (0)

My wife and I both have iphone 4s and the cradle... Plugged in is never an issue but it's funny.... when we both are in the car and the fone is not in the cradle, it's a hit and miss what fone the iDrive picks up. Very amusing. Like Southern22 said before......... my problem is going somewhere with the fone in the cradle then leave it in the car!!!!!!!!! ARRRGH !!! ( brain fart!! )
M6-4KIX is offline   Canada
Appreciate 0
Reply With Quote
      11-17-2012, 09:30 AM   #3
andreo
3
BMW Enthusiast
 
andreo's Avatar
 
Drives: Citrin Black 650i Coupé (F13)
Join Date: Jul 2012
Location: Macau

Posts: 352
iTrader: (0)

The iPhone 4S I am using is like Southern's. I use it as a music source only. Unfortunately, it does not activate consistently when I start the car. Very puzzling.
andreo is offline   Macao
Appreciate 0
Reply With Quote
      11-17-2012, 12:04 PM   #4
greenie
0
Private
 
Drives: 2013 650i x-drive m-sport coup
Join Date: Oct 2006
Location: Jenkintown, Pa

Posts: 64
iTrader: (0)

No problem here Andreo with my 4S.
greenie is offline   United_States
Appreciate 0
Reply With Quote
      11-18-2012, 01:56 AM   #5
southern6er22
8
Southern6er22
 
Drives: 2012 650i xDrive M Sport Coupe
Join Date: Jan 2012
Location: Alabama

Posts: 834
iTrader: (0)

Garage List
Quote:
Originally Posted by andreo
The iPhone 4S I am using is like Southern's. I use it as a music source only. Unfortunately, it does not activate consistently when I start the car. Very puzzling.
I don't cradle - just the white cord - but it sometimes takes a few minutes to recognize that it should wake up and do its job. If I don't hear the tone by the time I'm in reverse, I usually open the console, push the Home button, and that gets it going.
southern6er22 is offline   United_States
Appreciate 0
Reply With Quote
      11-18-2012, 03:21 AM   #6
andreo
3
BMW Enthusiast
 
andreo's Avatar
 
Drives: Citrin Black 650i Coupé (F13)
Join Date: Jul 2012
Location: Macau

Posts: 352
iTrader: (0)

Quote:
Originally Posted by southern6er22
Quote:
Originally Posted by andreo
The iPhone 4S I am using is like Southern's. I use it as a music source only. Unfortunately, it does not activate consistently when I start the car. Very puzzling.
I don't cradle - just the white cord - but it sometimes takes a few minutes to recognize that it should wake up and do its job. If I don't hear the tone by the time I'm in reverse, I usually open the console, push the Home button, and that gets it going.
Oh yes. That's right. Unfortunately, pushing the home button does not wake the device for my case. Still trying to figure out.
andreo is offline   Macao
Appreciate 0
Reply With Quote
      11-18-2012, 09:16 AM   #7
BMWrules7
10
Major
 
Drives: 2011 750Li, Alpine White
Join Date: Mar 2011
Location: Boston Area

Posts: 1,056
iTrader: (0)

Quote:
Originally Posted by andreo
Has any of you experienced your iPhone not enabled at car startup? I have an iPhone 4S attached to a Media Snap-in Adapter and intermittently, it is shown as disabled on the iDrive under External Devices. I need to pop the adapter up and reinsert before the iPhone gets recognized. Very odd.
Yes. Reseat your snap in adapter. (i.e., remove the snap in adapter and replace it using moderate force).

This should cure it for a while. When it fails again in three months follow this sane procedure again.
BMWrules7 is online now  
Appreciate 0
Reply With Quote
      11-18-2012, 06:15 PM   #8
andreo
3
BMW Enthusiast
 
andreo's Avatar
 
Drives: Citrin Black 650i Coupé (F13)
Join Date: Jul 2012
Location: Macau

Posts: 352
iTrader: (0)

Thanks. That appears to be the only solution at the moment. Still trying different configurations between the snap-in phone and my mobile phone.
andreo is offline   Macao
Appreciate 0
Reply With Quote
      05-26-2013, 09:39 AM   #9
andreo
3
BMW Enthusiast
 
andreo's Avatar
 
Drives: Citrin Black 650i Coupé (F13)
Join Date: Jul 2012
Location: Macau

Posts: 352
iTrader: (0)

Good news! I may have found the source of the problem of this iPhone startup inconsistency. It turns out the issue is a setting in the iPhone as opposed to iDrive. All we have to do is to turn off AutoLock and the problem goes away. So far I have tested it overnight and after a variety of idle times. The music comes right back on as soon as iDrive boots up. Give it a try and see whether it works the same in your cars. My iPhone settings attached.
Attached Images
 
andreo is offline   Macao
Appreciate 0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:33 PM.




6post.com
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST